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ENVI LiDAR クイックリファレンス 

ENVI LiDAR は LiDAR データの解析を行うソフトです。一度の処理の実行で LiDAR の点

群データから、DEM や DSM、建物、樹木、送電線や電柱などを抽出し、様々なファイル

フォーマットで出力することが可能です。大容量の LiDAR ポイントデータを高速に取り扱

えることも魅力の一つです。 
 

ENVI LiDAR での標準ワークフロー 

ENVI LiDAR で処理を行う流れは以下のようになります。 
 
 
 
 
 
 
 
ENVI LiDAR の起動 
スタート→すべてのプログラム → ENVI 5.4 → Tools → ENVI LiDAR 5.4 (64bit) をク

リックしてください。 
あるいは、ENVI5.4 インターフェースのツールボックスの Launch ENVI LiDAR メニュー

から起動することもできます。 
 
プロジェクトを開く 
新規プロジェクトの作成 

メニューから File→New Project..を選択します。 
新規プロジェクトの任意の名前を入力し、任意の場所へ保存してください。 

既存プロジェクトを開く 

メニューから File→Open..を選択します。 
 
データの読込 
新規プロジェクト作成後、任意の LAS またはテキストファイルを指定してください。 
例：インストールフォルダのサンプルデータ 
C:¥Program Files¥Harris¥ENVI54¥data¥lidar¥DataSample.las 
Shift キーや Ctrl キーを使用し、複数のデータを一度に読み込むことが可能です。 
ファイルを読み込み後、自動的に地図参照情報をファイルから読み、確認を行うダイアログ

データ読込 Density Map 作成 処理パラメータ設定 

処理実行 処理結果 QA 実施 再処理実行 
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が表示されます。 

 
図 1. 地図参照情報確認ダイアログ 

表示された情報を使用する場合は、「はい(Y)」を選択してください。 
任意の地図参照情報を付与する場合は「いいえ(N)」を選択し、以下の読込データ詳細設定

を参照し、設定を行ってください。地図参照情報がファイルから読み込めない場合も以下を

参照してください。 
 

読込データ詳細設定 

地図参照情報がファイルから読み込めない場合は、ポイントの属性や投影法を設定し

ます。 

 
図 2. 読込データ詳細設定 
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1. File Content 

データが txt ファイルなどで地図参照情報などが読み込めない場合は、各列に合った

属性情報を設定することができます。各列（Ignore）をクリックし、表示される属性

から該当のものを選択してください。 

 
図 3. 属性情報 

2. Coordinate System では、入力データの地図投影法や測地系を設定します。Input 
Projection System のプルダウンボタンをクリックし投影情報を選択します。 

 Geographic Lat/lon：緯度経度 

 UTM：横トランスバースメルカトル 

 Geocentric：地心座標 

 Arbitrary：投影法が不明な場合 

 Advanced：上記以外の場合 

Advanced を選択すると図 4. Select Coordinate System が表示され、様々な地図投影

法や測地系を選択できます。日本の 19 座標系も Advanced から選択可能です。 
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図 4. Select Coordinate System 

3. View Headerでは、lasデータのヘッダファイルを参照し、座標などの確認を行えます。 

ENVI LiDAR ウィンドウの紹介 

  
 
 

2. Navigate Window 

3. Operation Log 

4. Main Window 

1. Layer Manager 

7. IDL Toolbox 

5. Toolbar 

6. StatusBar 
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図 5. ENVI LiDAR 各ウィンドウ 

1. Layer Manager 

解析処理後、各項目のチェックを ON/OFF することにより、表示の ON、OFF を行い

ます。樹木や建物の表示を OFF することで、簡単に抽出したオブジェクトの確認を行

えます。 

2. Navigate Window 

データ全体を表示しています。ピンクの範囲が Main Window へ表示されます。

Navigate Window 上へマウスを移動すると、このウィンドウの左下へ X、Y、Z の情報

が表示されるので、データ全体のおおよその最低、最高の高さ情報を確認できます。各

+、-の記号がついた虫めがねツールでズームイン、ズームアウトを行うことができます。

でデータの表示範囲を移動します。矢印のアイコンは Quality Assurance を行う

範囲の移動及びリセットに使用します。 

3. Operation Log 

各処理のログを表示します。Export to Text File ボタンでログをファイルへ保存しま

す。プロジェクト情報もこのウィンドウに表示することができます。プロジェクト情報

の表示：File→Project Information 

4. Main Window 

データ読み込み後は、高さ情報を元にカラーが付与され、表示されています。カラー表

示をしない場合は、Color by Height ボタンをクリックしてください。Navigate 
Window のピンク枠内の点群データを表示します。マウス操作でデータをあらゆる角

度から確認することが可能です。 

 センターホイール、あるいは右クリック+ドラッグ：ズームイン、ズームアウト 

8. Cross Section Window 
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 左クリック+ドラッグ：表示の回転 

 左右クリック+ドラッグ：全体の表示位置の平行移動 

5. Toolbar 

よく使用する機能をアイコンとして表示しています。詳細は「Toolbar の紹介」を参照

してください。 

6. Status Bar 

Main Window 上のカーソルの示すポイントの X、Y、Z や Intensity などの情報が表示

されます。 

7. IDL Toolbox 

IDL で作成したツールの Toolbox です。各ツールはダブルクリックで起動します。 
デフォルトでは非表示になっていますので、View メニューの IDL Toolbox をチェック

することで表示されます。 

8. Cross Section Window 

クロスセクションで指定した範囲の断面を表示します。このウィンドウでも、Main 
Window と同じマウス操作が行えます。クロスセクションツールはメニューの View→

Select Cross Section Line をクリックすることで使用できます。（ アイコンからも

使用できます）Cross Section Window をアクティブにして、キーボードの Ctrl+C を

押下すると断面図をプロジェクトフォルダ下にビットマップファイルに保存できます。 

 

参照ファイルのインポート 
メニューから File→Import メニューから、各種参照ファイルをインポートします。 

1. Background Shape File… 

QA 処理の際にシェープファイルにて指定する処理範囲をインポートします。 

2. Precision Test Points… 

ポイントの名前、数、座標が記載された精度参照テストポイントを ASCII ファイルで

読み込むことが可能です。 

3. Power Poles Locations from File… 

鉄塔の座標が記載された ASCII ファイルを読み込むことが可能です。 
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4. Orthophoto Tiff File… 

LiDAR データの強度から作成される Orthophoto に替わり、読み込んだ Tiff ファイル

を Orthophoto として使用します。 

 
図 6. 参照ファイルインポートメニュー 
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Toolbar の紹介 
ここでは、メニュー下部に配置されているツールバーについて紹介します。以下の表は、ツ

ールバーのアイコンの機能を左から順に説明しています。 
表 1. ENVI LiDAR ツールバー 

アイコン / 機能名 機能 

 New Project 
新規プロジェクトを作成します。 

 Open Project 
既存プロジェクトを開きます。 

 Process Data 
処理パラメータ設定ウィンドウを表示します。 

  QA modes 
Process Data で解析処理を行ったデータを QA モ

ードにし、結果の確認、修正を行います。もう一度

クリックすると元の点群データの表示を行いま

す。処理範囲に Center Line を設定し、処理を行

った場合は、矢印マークの QA モードを使用して

ください。 

 3D Viewer 
三次元鳥瞰図を表示します。 

 Cross Section 
クロスセクションを使用することができます。

Cross Section window も表示されます。 

 2D View 
表示しているデータの範囲を上空から見た二次元

図で Cross Section window へ表示します。 

 Perspective View 
データの表示角度をリセットし、遠近法で Main 
Window へ表示します。 

 Isometric View 
データの表示をリセットし、上空から見た二次元

図を Main Window へ表示します。 

 Measurement Tool 
マウスで指定した始点、終点の位置や、X・Y・Z の

そ れ ぞ れ の 差 分 、 2 点 間 の 距 離 と 角 度

（ Slant/Horizontal range and angle ） を

Operation Log へ表示します。また、Horizontal 
range と Z の差分、Slant range は Main Window
へ注釈としても表示されます。 

 Height Palette Editor 
高さデータのカラーパレットを作成、編集します。
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 Color by Height 
高さデータのカラーパレットの ON/OFF を切り替

えます。 

 Shade by Intensity 
強度データの陰影の ON/OFF を切り替えます。 

 Color by RGB 
RGB データのカラーリングの ON/OFF を切り替

えます。 

 Viewshed 
Viewshed Analysis モードに入ります。 
 

 Filter Points by Height 
QA モードで、高さデータに閾値を設定しポイント

データのフィルタリング（表示/非表示）を制御で

きます。 

 Launch in ENVI 
選択したファイルを ENVI で開きます。 

 Launch in ArcMap 
選択したファイルを ArcMap で開きます。 

 Screenshot to PowerPoint 
Main Window のイメージ画像を Power Point に

出力します。 

 
Density Map の作成 
メニューの Process→Generate Density Map をクリックすると、出力ファイルフォーマッ

トを設定するウィンドウが開きます。出力フォーマットを指定し、OK をクリックすること

で Density Map が作成されます。 
表示された画像が Density Map です。Density Map 上にカーソルを置くと、そのポイント

の座標と点密度が右上にある Navigate の枠内へ表示されます。画面の Navigate にある矢

印ボタンは左から、ズームイン、ズームアウト、各方向へ画像を移動させるパンの動作を行

います。 
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図 7. Density Map 
処理パラメータ設定 

1. Process Data をクリックし、処理パラメータ設定ウィンドウを表示してください。

Output タブでは、処理結果の出力ファイルと出力ファイル形式を設定します。 

出力したい結果にチェックをし、ファイル名とファイル形式を選択してください。 
その他、Export Coordinate System で出力データの地図投影法の設定、Products 
Folder で出力ファイル先、Parameter Templates で今回の処理をテンプレートとして

保存するなどを確認し、Area Definition タブをクリックしてください。 
 

 
図 8. 処理パラメータ設定ウィンドウ – 出力ファイル設定 
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2. Area Definition タブでは処理を行う範囲を設定します。左に表示されている Density 
Map 上でマウスをドラッグし、処理を行う範囲を指定してください。Center Line for 
QA を使用すると、読み込んだベクタデータをもとに QA を実施します。 

 

図 9. 処理パラメータ設定ウィンドウ – 処理範囲設定 

3. Production Parameter タブをクリックし、処理パラメータの設定項目を表示します。

オブジェクト抽出を行うものに対して、各パラメータの設定を行ってください。 

 

図 10. 処理パラメータ設定ウィンドウ – 処理パラメータ設定 
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4. すべての設定が終わりましたら、処理パラメータ設定ウィンドウの右下にある Start 
Processing ボタンをクリックし、処理を実行させてください。 

  

＜注意：パラメータについて＞ 
General： 
この項目はファイルの一般的な情報を設定します。Clip Minimum Height
に、データの最小、Clip Maximum Height に最大の高さを設定していただく

ことで、エラーポイントなどを除外して処理します。これらの情報は

Navigate Window 上でマウスを移動させることにより、ウィンドウの左下に

高さ情報が表示されますので、それを参考に値を設定してください。

Maximum Points Density にはデータの 1 平方メートルあたりの最大点密度

を設定してください。 
 
DEM： 
Grid Resolution は DEM の解像度を決定します。点密度の低いデータの場合

は 0.5m を選択すると良い結果を得られない可能性があります。また、 
DEM のパラメータ設定では、データの点密度が 1 平方メートルに 5 ポイント

未満の際場合は Filter Lower Points の設定を Do Not Filter と設定してくだ

さい。また、DEM Advanced Parameters..をクリックし、Variable 
Sensitivity Algorithm へチェックを入れてください。Variable Sensitivity 
Algorithm は点密度の低い森林のエリアで、ポイント間に開きのあるデ

ータに効果を発揮します。チェックを入れると DEM Sensitivity の設定

が有効になります。DEM Sensitivity はポイントに反応する感度をあらわしま

す。高低差のあるとがった山間部では高い値を設定してください。ただ

し、高い建物を地表の一部としてしまうことがありますので注意してく

ださい。あまり高低差のないなだらかな山間部では低い値を設定してく

ださい。 
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出力結果の確認 
処理実施後、出力されたファイルを確認します。出力ファイルは処理パラメータ設定ウィン

ドウの Outputs タブにある Products Folder に設定されているフォルダへ出力されていま

す。設定したファイルが出力されているか確認してください。 

 

図 11. 出力ファイル一例 – OrthoPhoto 
処理結果 QA 実施 
QA のアイコンまたは、Edit→QA Mode をクリックすることで Quality Assurance を開始

します。Navigate window の ボタンをクリックすることで、QA を実施するブロッ

クを次のブロックへと移動します。 では QA を行った範囲をリセットし、開始位置へ戻

ります。 で Jump フィールドの距離だけジャンプします。 

全体的にオブジェクトの抽出結果が良好ではない場合は、処理パラメータを変更し、再度処

理を実行することを推奨いたします。 
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図 12. QA モードでのデータ表示 
 

 

1. 樹木への QA 実施 

1.1 修正を行う樹木の範囲に Cross Section ツールを使用し、Cross Section View を

表示してください。その後、修正を行う樹木をダブルクリックし、New Correction
をクリックしてください。 

＜注意＞ 

1. 各オブジェクトの色の確認および設定は、File→Preference メニューから

行ってください。 

2. QA で修正を行ったオブジェクトには、赤い下向き三角のマーク が付

与されます。このマークは樹木、送電線など全てのオブジェクト共通で

す
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図 13. Cross Section での樹木の表示 

1.2 Correction Item ウィンドウが表示されますので、修正したい項目にトグルを合

わせてください。Tree-Edit を選択した場合は、Radius と Height の編集ができ

ますので、樹木の幅、高さを調整していただけます。 

1.3 樹木モデルが付与されていない緑の点群は、樹木としてカウントされていません

ので、任意の場所で Tree-Set を使用し、樹木モデルを追加してください。 
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図 14. オブジェクト修正ウィンドウ 

2. 建物への QA 実施 

2.1 修正を行う建物のラインをダブルクリックしてください。Delete Building 
Contour を選択すると、選択したラインが削除されます。 

 
図 15. 建物のベクタ修正メニュー 
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2.2 Edit Building Contour を選択すると、Cross Section ウィンドウが表示されま

すので、そこで各頂点を移動させます。また、ポイント上で右クリックすること

でサブメニューが表示されますので、頂点の削除などサブメニューから実施する

ことが可能です。 

 
図 16. 建物のベクタ修正サブメニュー 

3. 鉄塔、送電線への QA 実施 

3.1 修正を行う鉄塔上でダブルクリックをしてください。New Correction を選択し、

修正のメニューを起動させてください。 

3.2 Power Pole – Set のメニューで鉄塔を追加できます。 

3.3 Power Pole – Remove のメニューで鉄塔を削除できます。 
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図 17. 電柱、電線の修正メニュー 

3.4 修正を行う送電線を Main Window 上でダブルクリックし、New Correction を

選択し、送電線の追加を行ってください。送電線は始点、中間点、終点の設定を

行います。 
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図 18. 送電線編集メニュー 

3.5 すでに送電線のオブジェクトが作成されており、修正を行う場合は Edit Power 
Line を選択してください。 

4. DEM への QA 実施 

4.1 修正を行うエリアをダブルクリックしてください。New Correction を選択し、

修正のメニューを起動させてください。 

4.2 Add to Terrain では、地表が正常に分類されなかった場合に、このオプションで

半径を設定し、地表面を追加します。(密林地などで地表が著しく窪んでいる際に

使用することが有効です。) 

4.3 Remove from Terrain では DEM や屋根として抽出したエリアを対象とし、この

設定を行うと、処理を再実行した際に指定した範囲を削除します。(地表の突出し

た範囲に使用することが有効です。) 

4.4 Filter Points in Radius では、範囲内にあるポイントは DEM 算出時に除外され

ます。 

4.5 Level Area では、選択したポイントの高さで指定したエリアの DEM を平らにし

ます。 
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図 19. DEM の修正メニュー 

5. 分類されたポイントを別の分類に変更する 

5.1 Cross Section で該当する箇所をダブルクリックし、New Correction with 
Contour をクリックします。 

5.2 赤いラインで該当箇所のポイントを囲みます。範囲を決めたら右クリックしてく

ださい。Correction Item ダイアログが表示されます。 

5.3 Change Classification Code が選択されていることを確認し、Classification の

プルダウンボタンから新しい分類を選択します。 
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図 20. 分類の変更メニュー 

5.4 Correction Item ダイアログで OK をクリックしてください。変更が反映されま

す。 

6. 修正内容の保存 

QA で修正した内容をメニューの Edit→Export List からファイルへ出力することが可

能です。 

 
修正の反映 - 再処理の実施 
QA の実施後、再処理を行うことで修正を行った結果を反映します。Process Data から再

処理を実行してください。特定のものだけ再処理を行う場合は、メニューの File→Export
から出力ファイルを選択し、処理を実行してください。ただし、Export で再処理を行える

ものは Buildings ベクタ、Trees リスト、Power Lines のみとなりますので、その他の修正

結果の反映は Process Data から行ってください。 
Export で修正が反映するものに関しては、QA の実施中にオブジェクトの設定値を確認で

きますが、Process Data を行う必要がある DEM などに関しては再処理を実施後に結果を

確認してください。 
 



 

22 
 

処理結果の 3D 表示 
出力ファイル設定時に Produce 3D Viewer Database にチェックを入れ、処理をした場合、

処理結果を 3D で表示することが可能です。ツールバーの 3Dviewer アイコンをクリック

し、結果を確認してください。3D を表示し、任意の場所をダブルクリックすることで、Main 
Window の表示がダブルクリックした場所へと移動します。QA モードの際も 3D 表示が行

えますので、3 次元のモデルを確認しながら、修正を行っていただけます。 
フライモードで上空を飛行しているように 3D 表示を確認するためには、A(前進)または Z、
Y(後退)キーを押下してください。また、この飛行ルートはメニューの Navigate→Record 
Route から記録することが可能です。 
F1 ボタンをクリックすると、3D 表示上にキー操作のナビゲーションが表示されますので、

希望に合った表示をキー操作で行ってください。 
3D 表示上でも Measurement Tool が使用できますので、メニューの Edit→Measurement 
Tool をクリックし、三次元上に測定したい場所の始点と終点をクリックにて設定してくだ

さい。X、Y に加え、高さの測定も行います。 

 
 図 21. 3D viewer の表示 – Measurement Tool での計測 
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Tips 
プロジェクトのサブセットを行う 
メニューの File→New From Current Project..メニューをクリックし、処理範囲を設定し

ます。次にプロジェクトの名前を設定することで、LAS ファイルの再読み込みを行うこと

なく、指定範囲のプロジェクトを作成することが可能です。 
 
処理時間について 
算出、出力するファイルにより、処理時間に違いがあります。以下の情報は、処理時間短縮

などを考慮する際に使用してください。 

1. DEM Contours 処理を行うと処理時間が増加します。 

2. DEM の Grid Resolution を 50cm に設定すると処理時間が増加します。 

3. DEM の出力ファイル形式を GeoTIFF に設定すると処理時間が増加します。対応策と

しては他のファイル形式で処理を実行し、処理終了後に GeoTIFF ファイルへと出力す

ることで処理時間の短縮を行えます。 

他出力ファイルに関しても、処理実行後にファイル形式の変更を行いたい場合は、

Export のメニューから出力を行うことが可能です。 

4. DSM 処理を行うと処理時間が増加します。 
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ENIV LiDAR + IDL でプログラミング 

ENVI LiDAR は、IDL という Exelis VIS 社製のデータ解析・可視化に優れたプログラミン

グ言語を使用することによって、ENVI LiDAR の機能を拡張すること（Extension）が可能

です。そのため ENVI LiDAR は、ユーザ独自のアルゴリズムを作成したり、バッチ処理な

どを追加することができる非常に柔軟なアプリケーションとなっております。ENVI 
LiDAR の機能を持つルーチンも用意されているため、プログラム内で ENVI LiDAR のオ

ブジェクト抽出機能などを呼び出すことも可能です。 
ここでは、IDL を使用し簡単なプログラムを作成し、メニューに追加します。 
 
機能拡張のワークフロー 
ENVI LiDAR で機能拡張を行う流れは以下のようになります。 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
IDL で ENVI LiDAR の機能を拡張する 
以下の手順で IDLで ENVI LiDARの機能を拡張します。ここでは、ENVI Toolboxに「Quick 
Sample」という、読み込んだデータのデータ範囲を表示する機能を追加します。 

1. IDL を起動します。スタート → すべてのプログラム → IDL 8.6 → IDL 8.6 をクリ

ックしてください。IDL の統合開発環境、IDL ワークベンチが起動します。ここで使

用する主な機能は以下の 2 つです。 

 エディタ：ソースコードの作成、編集ができるソースコードエディタです。 

 コンソール：コマンドラインです。コマンドの入力や、システムからのメッセージ

の表示が出力されます。 

IDL の起動 

コーディング 

コンパイル 

SAVE ファイル作成 

フォルダへ配置 
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※IDL ワークベンチの詳細は IDL ヘルプシステムを参照してください。 

  

図 22. IDL ワークベンチ 

2. コーディングを行います。IDL ワークベンチの新規ファイルアイコン をクリッ

クしてください。中段右のソースコードエディタに新規ファイルが表示されます。以下

のソースコードを記述してください。IDL のプログラミングの詳細については IDL ヘ

ルプシステムを参照してください。 

 

【ソースコードの処理内容】 

ENVI のインストールフォルダにある LiDAR サンプルデータを読み込み、データ範囲

を表示します。 

例：インストールフォルダのサンプルデータ 

C:¥Program Files¥Harris¥ENVI54¥data¥lidar¥DataSample.las 

【ソースコード】 

※コードの左側にある数字は行番号を示していますのでエディタへは入力しないでく

ださい。 

エディタ 

コンソール 
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※プログラムは pro というステートメントから始まり、ルーチン名を続けます。 

※最後は end というステートメントで終了します。 

※「;」セミコロンで始まる行はコメント行です。 

 

1 pro quick_sample 

2  

3   ; コンパイルオプションの設定 

4   COMPILE_OPT IDL2 

5    

6   ; 現在の ENVI LiDARを指定します。 

7   e = envi(/CURRENT) 

8   elv = ENVIpointcloudviewer()  

9    

10   ; サンプルファイルを指定します。 

11   file='C:¥Program Files¥Harris¥ENVI54¥data¥lidar¥DataSample.las' 

12  

13   ; サンプルファイルを開きます。 

14   lidar = e.Openpointcloud(file, project_URI='C:¥DEMO¥testLidar') 

15  

16 ; サンプルファイルを ENVI LiDAR上に表示します。 

17 elv.display, lidar 

18  

19   ; 読み込んだファイルのデータ範囲を取得します。 

20   datarange = lidar.GetDataRange() 

21  

22    ; 取得したデータ範囲を表示します。 

23   PRINT, 'Data Range: ', datarange 

24    

25 END 
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【ソースコードの説明】 

4 行目 COMPILE_OPT IDL2 コンパイルオプションです。IDL のデフォルトの

INT 型は 16bit ですが、32bit になるようなオプシ

ョンです。 

7 行目 envi() ENVI オブジェクトを生成する関数です。戻り値の

e に生成オブジェクトが入ります。ここでは

CURRENT キーワードを設定しているので、現在

起動中の ENVI セッションを取得しています。 

8 行目 
ENVIpointcloudviewer() 

ENVIpointcloudviewer オブジェクト(ENVI API
上での ENVI LiDAR の呼称)を生成する関数です。

戻り値の elv に生成オブジェクトが入ります。

ENVI LiDAR インターフェースを起動します。 

20 行目 e.Openpointcloud() 7 行目で作成したオブジェクト e の ENVI メソッド

を呼び出しています。第一引数に指定される

LiDAR データをオープンします。project_URI キ
ーワードに ENVI LiDAR のプロジェクトファイル

作成フォルダを指定します。戻り値は読み込んだデ

ータのオブジェクトです。 

17 行目 elv.display 8 行目で作成したオブジェクトの ENVI LiDAR メ

ソッドを呼び出しています。ENVI LiDAR ディス

プレイに、LiDAR データを表示します。 

20 行目 
lidar.GetDataRange() 

15 行目で作成した LiDAR データオブジェクト

lidar の GetDataRange メソッドで、読み込んだデ

ータの X, Y, Z の最小値と最大値を取得します。 

23 行目 PRINT PRINT プロシージャで標準出力（IDL コンソール

ウィンドウと ENVI LiDAR の Operation Log）に

メッセージを出力します。 

3. ソースコードの記述が完了したら保存します。保存アイコン をクリックし、任意

の場所に保存してください。ファイル名はルーチン名と同一である必要があります。

quick_sample.pro という名前で保存してください。 
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4. 作成したプログラムをコンパイルします。まずは、IDL のセッションをリセットし、メ

モリなどの状態をクリアします。以下のコマンドを IDL ワークベンチのコンソール画

面から入力してください。コマンドは入力後にEnterキーを押すことで実行されます。 

IDL> .RESET_SESSION 

5. カレントディレクトリを、ソースコードを保存したディレクトリに移動します。その後、

quick_sample.pro をコンパイルします。以下は C:¥Quick_Sample に保存した場合の

例です。 

IDL> CD, 'C:¥Quick_Sample' 

IDL> .compile quick_sample.pro 

6. メインプログラムからコールされるサブルーチン(関数/プロシージャ)をすべてコンパ

イルします。ここでは、E3DE のルーチンがエラーとなってしまいますので、エラーが

発 生 し て も 続 け て コ ン パ イ ル す る よ う に 、「 SKIP_ROUTINE 」 と

「CONTINUE_ON_ERROR」を追加します。 

IDL> RESOLVE_ALL, /CONTINUE_ON_ERROR, SKIP_ROUTINES='envi' 

7. コンパイルしたコードから SAVE 形式のファイルを作成します。ファイル名はソース

コードのファイル名と同一で、拡張子は.sav とする必要があります。 

IDL> SAVE, FILENAME='quick_sample.sav', /ROUTINES 

8. 作成した SAVE ファイルをインストールディレクトリの extensions ディレクトリへ保

存します。 

例：C:¥Program Files¥Exelis¥ENVI53¥extensions¥quick_sample.sav 

9. ENVI を e=envi()コマンドで起動します。 

10. ENVI の Toolbox の Extension フォルダに Quick_Sample が追加されていることを確

認してください。 

11. Quick Sample をダブルクリックすると、ENVI LiDAR ディスプレイが起動して、

LiDAR データを表示し、Operation Log に以下のように表示されます。数値は左から

順に、Xmin, Ymin, Zmin, Xmax, Ymax, Zmax を表わします。 

Data Range: 593741.09 5289518.5 334.01000 594285.08       

5290062.5    361.04000 
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参考 
IDL による機能拡張の詳細は ENVI ヘルプシステムの以下の項目を参照してください。 
ENVI ヘルプ： 
ENVI メインメニュー->Help->Help Contents 
 
項目： 
Toolbox Extensions について 
ENVI Help->Programming->Programming Guide->Advanced Concepts->Toolbox 
Extensions 

 



 

 
 

 


